Acrobat Reader for HP-UX

인터넷 뿐만 아니라 컴퓨터를 이용한 주위 분들과 정보 교환을 위한 수 많은 레퍼런스 문서들이 어느 순간부터 PS(PostScript)가 아닌 Adobe의 PDF(Portable Document Format)로 표준화(?)된 상태이기 때문에, UNIX 환경에서도 PDF 뷰어는 이제 필수적인 유틸리티가 되었다고 하겠다. 당연히 웹 브라우저 내 혹은 다운로드하여 볼 수 있기 위해서는 아크로뱃 리더와 웹 브라우저를 위한 플러그-인이 필수적이라고 할 수 있겠지만, 예나 지금이나 상황은 녹녹치 않은 것이 현실이다. 굳이 Linux나 FreeBSD 등을 언급할 필요는 없겠지만,  SUN Solaris를 제외한 UNIX 운영체제는 이제 더이상 데스크탑 환경에 남아 있지 않기 때문에 이러한 현실에 대한 대응을 개발사등에 바란다는 것이 무리인 것은 당연한다.

HP-UX 11i를 위한 아크로뱃 리더 7을 설치한 후, 특정 라이브러리를 찾을 수 없다면 에러 메시지를 보게 되었다. 이를 해결하기 위해 해당 라이브러리가 있는 디렉토리를 환경변수 SHLIB_PATH에 추가하거나 지정해 주니 정상적으로 구동이 시작되었다. 하지만, 웹 브라우저 플러그-인의 PPKLite.api의 로딩에 관하여 또 다른 에러가 발생했다. 다행히 플러그-인 관련인지 애크로뱃 리더의 구동은 성공했다. 매번 이러한 경우를 당하게 되자, 단순히 해당 플러그-인 관련 파일을 다른 디렉토리를 옮기거나 삭제해 버리자 에러 메시지없이 구동이 가능하게 되었다. PPKLite.api가 도대체 무슨 기능을 수행하는지 궁금하다.

현재 HP-UX용 Acrobat Reader의 최종 설치 버전은 7.0.9이다. 시스템 요구 사항에는 PA-RISC 8800과 512MB의 이상의 메모리를 요구한다고 되어 있지만 확실한 근거는 없는 듯 하다. 512MB은 HP-UX 11 이상의 구동에는 턱없이 모자란 용량이다. UNIX용 Acrobat Reader에 대한 지원 사항은 HP-UX나 AIX는 거의 비슷한 처지이며, Solaris(SPARC 및 X86)와 Linux는 8.1.3 버전까지 지원이 가능하다.

Advertisements

답글 남기기

아래 항목을 채우거나 오른쪽 아이콘 중 하나를 클릭하여 로그 인 하세요:

WordPress.com 로고

WordPress.com의 계정을 사용하여 댓글을 남깁니다. 로그아웃 /  변경 )

Google+ photo

Google+의 계정을 사용하여 댓글을 남깁니다. 로그아웃 /  변경 )

Twitter 사진

Twitter의 계정을 사용하여 댓글을 남깁니다. 로그아웃 /  변경 )

Facebook 사진

Facebook의 계정을 사용하여 댓글을 남깁니다. 로그아웃 /  변경 )

w

%s에 연결하는 중